Android 4.2 applications available for your Android 4.0 device

Since Android Police leaked the updated Gmail application a few weeks ago, a number of other applications from Android 4.2 have been leaked online. You can now download the entire system dump from the LG Nexus 4, but it probably won’t do you much good. Some helpful people around the internet have packaged some of the applications into zip files that you can install on your Android 4.x devices right now. The keyboard, camera and gallery all seem to work fine on my Nexus S, but the clock force closes when you try to add an alarm. Apparently, Galaxy Nexuses do not have this problem. Click the links below to download the various components, and then flash through your custom recovery:

Hopefully Google will push the new, updated Jellybean to AOSP and Nexus devices within the next couple of weeks, but hopefully these leaks will be enough to tide us over until then.

, ,

About the author

James recently graduated law in Melbourne, and decided to run away to London to avoid getting a real job. In between long walks on the beach and eating by candlelight, he enjoys boring people with rants about technology. He has... (read more)


  • http://www.facebook.com/profile.php?id=680485277 Tom Rubery

    Will these apk’s work with devixes with touchwiz?

    • dejavu

      I think these require stock android framework to work.

      • ds22

        Indeed they do. Running JB 4.1.2 with Franco Kernel and the gallery / camera doesn’t work.

      • ds22

        This appears to be the case. Running JB 4.1.2 with Franco Kernel. Camera / Gallery doesn’t work.

      • ds22

        This appears to be the case. Running JB 4.1.2 with Franco Kernel. Camera / Gallery doesn’t work.

      • ds22

        This appears to be the case. Running JB 4.1.2 with Franco Kernel. Camera / Gallery doesn’t work.

    • James Finnigan

      Not sure. I can’t test it for you, but I believe that as long as you’re rooted, the applications should work. If you decide to try it, let us know.

    • David Watt

      Yep, should work no problem.

  • http://twitter.com/DKlavo David Klaverstyn

    I’ve installed the Camera App and Launcher on my I9000. The Camera functions work but the panaromic function comes up with a “Sorry, your device is not yet supported. Model : GT-I9000 (samsung)”

    • David Watt

      Some of the versions posted on XDA require you to edit your build.prop to change your model to the Nexus. But there are other versions that don’t need the edit to get it working.

  • ds22

    Totally broke my gallery. JB 4.1.2 (with Franco kernel). <- This is the problem, I expect.