sgs5 foxtel go
Some good news for Foxtel customers who recently purchased the Samsung Galaxy S5, with Foxtel updating the Google Play store to now allow installation on Samsung’s latest flagship.

As well as the Galaxy S5, Foxtel has updated compatability to include the Samsung Galaxy S4 (GT-i9506) and the Galaxy Tab 3 7″ (SM-N9007). While the Galaxy S5 runs Android 4.4 (KitKat), and some Galaxy S4 (GT-i9506)’s have received KitKat officially, the Play Store entry still advises that compatability is limited to devices running Android 4.3.

This is great for Samsung owners, but there’s still no mention of any updates going out to other manufacturers. But according to Community Manager ‘Nik’ who announced the update, they have begun testing other devices, with Nik asking for suggestions on which devices to test.

Good news for some anyway. If you’ve got one of the compatible devices and a Foxtel subscription head over to the Google Play store and grab the app….or download the APK ;).

Source(s): Foxtel Support
  • phantomsofthedesert

    The day S5 was released. my Google account backup all my data and application which included Foxtel Go, Foxtel View. it has been working since initial install