pixel-box-front-2

A number of Pixel users in Australia are reporting that some popular sites, which have had mobile-optimised sites in the past, are refusing to load properly on their new phones. We’ve noticed this ourselves, especially when browsing certain Fairfax and News Limited properties. It’s rather frustrating, because the desktop versions of these sites are rather heavy and render awfully on mobile. Even deliberately specifying mobile URLs (e.g. m.smh.com.au) doesn’t get the mobile version to load.

On Whirlpool, users have reported the issue and having raised it with Google Support as well. It seems, for now, that the issue lies on the part of Fairfax, News Limited and other websites, but it isn’t peculiar to Pixel phones; other users have noticed that last year’s Nexus 5X and Nexus 6P are having the same issue when running Android 7.1 preview versions.

SMH when viewed on Pixel
SMH when viewed on Pixel

Quite likely the issue is in how these websites detect whether a requesting browser is a mobile or not, and Android 7.1 is causing some confusion. Hopefully they’ll have it fixed soon, otherwise you’ll just have to resort to reading Ausdroid, which works beautifully on all mobile devices.

Thanks: Anthony.
    11 Comments
    newest
    oldest most voted
    Inline Feedbacks
    View all comments
    whispy_snippet
    whispy_snippet
    3 years ago

    This is STILL rampant. Lots of sites keep showing up in desktop mode with mobile view seemingly inaccessible. This is really not good. Google should be onto this by now.

    whispy_snippet
    whispy_snippet
    3 years ago

    I’ve sent an email to Fairfax outlining this issue along with a link to this article. They’ve said it’s under review so hopefully we see a fix soon.

    Robert
    Robert
    3 years ago

    This has been happening in 7 & 7.1 on my 5X for months now

    Chris
    Chris
    3 years ago

    News limited….. hmmm

    caeci11ius
    caeci11ius
    3 years ago

    Their code that identifies your platform from browser referrer probably doesn’t recognise Android 7.1. Change referrer and it will likely work again.

    Geoffrey D'Unienville
    Geoffrey D'Unienville
    3 years ago

    Yep definitely been having scaling issues with my nexus 6p since 7.1, its a 7.1 issues and not a pixel issue as its happening to alot of my friends with 5x’s and 6ps as well, its annoying because its inconsistent, sometimes the pages will load then when they refresh or if i click a link and go back their back to full version of site

    TT
    TT
    3 years ago

    Chris, did you notice my issues with Pixel xl? There is gap between display and frame. I have photo here.

    Chris
    Reply to  TT
    3 years ago

    Didn’t see them mate, I do miss things sometimes. Email them through I’ll take a look.

    TT
    TT
    Reply to  Chris
    3 years ago

    Where can I look for your email? Thanks

    Jamie S
    Jamie S
    3 years ago

    I though it was just me, thanks Chris

    Ramiro Fernandez
    Ramiro Fernandez
    3 years ago

    Not just pixel, happens on my Nexus 5x on 7.1